OSPF路由重分发 孙阳 高级路由 - 小浣熊博客

OSPF路由重分发 孙阳 高级路由

发布者: 小浣熊

全网最全的网络资源分享网站

手机扫码查看

特别声明:文章多为网络转载,资源使用一般不提供任何帮助,特殊资源除外,如有侵权请联系!

这篇文章总字数为:4265 字,有 0 张图存于本站服务器

实验设备:

  • windows系统
  • CiscoPacketTracer工具软件

要求组网拓扑:

我的拓扑图:

拓扑连好后,配置路由器和计算机。

进入路由配置

你也可以通过物理方式打开端口,设置端口ip地址设置rip,小白请勿尝试!记不住容易弄乱,还是乖乖按下面的命令配置rip和ospf吧,不过,开启端口可以在这里开,和命令输入的no shutdown效果是一样的。

路由器几种常见状态:

  1. 路由初级状态:Router>
  2. 特权模式状态:Router#
  3. 全局模式状态:Router(config)#

路由配置关键命令:

进入路由特权模式:Router>en

进入路由全局模式:Router#conf

配置路由器名字:Router(config)#hostname 名字

进入端口F端口:Router(config)#int f0/0

进入端口G端口:Router(config)#int g0/0

进入端口S端口:Router(config)#int s0/0

创建loop口:Router(config)#int loop0

配置端口ip地址:Router(config-if)#ip add 192.168.1.1 255.255.255.0

打开F、G、S端口:先进入端口Router(config)#int g0/0,再Router(config-if)#no shutdown,也可以通过物理方法打开端口,端口一定要开,不开不通,全红。

返回上一级:exit

查看路由表:Router#sh ip ro

查看路由器配置信息:Router#sh run

保存路由器配置信息:Router#write

本次作业重分发rip配置:

Router(config)#router rip

Router(config-if)#redistribute ospf 1

Router(config-if)#net 192.168.1.0

Router(config-if)#net 192.168.11.0

Router(config-if)#no auto-summary

本次作业重分发ospf配置:

Router(config)#router ospf 1

Router(config-if)#log-adjacency-changes

Router(config-if)#redistribute rip metric 10 metric-type 1 subnets

Router(config-if)#network 192.168.2.0 0.0.0.255 area 0

本次作业普通ospf配置:

Router(config)#router ospf 1

Router(config-if)#log-adjacency-changes

Router(config-if)#network 192.168.2.0 0.0.0.255 area 0

Router(config-if)#network 192.168.3.0 0.0.0.255 area 2

普通ospf协议:

Router(config)#router ospf 1

Router(config-if)#log-adjacency-changes

Router(config-if)#net 192.168.3.0 0.0.0.255 area 2

Router(config-if)#net 10.4.1.0 0.0.0.255 area 2

普通rip协议:

Router(config)#Router rip

Router(config-if)#net 192.168.1.0

具体每台路由器配置详见下面路由器配置信息!!!

配置路由器

下面配置信息中红色加粗的是真正要敲的命令!!!

R1配置:

R1#sh run

Building configuration...

Current configuration : 779 bytes

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname R1

ip cef

no ipv6 cef

license udi pid CISCO1941/K9 sn FTX1524T465

spanning-tree mode pvst

interface Loopback0

ip address 1.1.1.1 255.255.255.255

interface GigabitEthernet0/0

ip address 192.168.11.1 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/1

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

interface Vlan1

no ip address

shutdown

router rip

redistribute ospf 1

network 192.168.1.0

network 192.168.11.0

no auto-summary

ip classless

ip flow-export version 9

line con 0

line aux 0

line vty 0 4

login

end

R2配置:

R2#sh run

Building configuration...

Current configuration : 893 bytes

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname R2

ip cef

no ipv6 cef

license udi pid CISCO1941/K9 sn FTX1524K906

spanning-tree mode pvst

interface Loopback0

ip address 2.2.2.2 255.255.255.255

interface GigabitEthernet0/0

ip address 192.168.2.1 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/1

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

interface Vlan1

no ip address

shutdown

router ospf 1

log-adjacency-changes

redistribute rip metric 10 metric-type 1 subnets

network 192.168.2.0 0.0.0.255 area 0

router rip

redistribute ospf 1 metric 3

network 192.168.1.0

no auto-summary

ip classless

line con 0

line aux 0

line vty 0 4

login

end

R3配置:

R3#sh run

Building configuration...

Current configuration : 798 bytes

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname R3

ip cef

no ipv6 cef

license udi pid CISCO1941/K9 sn FTX1524BS04

spanning-tree mode pvst

interface Loopback0

ip address 3.3.3.3 255.255.255.255

interface GigabitEthernet0/0

ip address 192.168.2.2 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/1

ip address 192.168.3.1 255.255.255.0

duplex auto

speed auto

interface Vlan1

no ip address

shutdown

router ospf 1

log-adjacency-changes

network 192.168.2.0 0.0.0.255 area 0

network 192.168.3.0 0.0.0.255 area 2

ip classless

ip flow-export version 9

line con 0

line aux 0

line vty 0 4

login

end

R4配置:

R4#sh run

Building configuration...

Current configuration : 792 bytes

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname R4

ip cef

no ipv6 cef

license udi pid CISCO1941/K9 sn FTX1524SMPA

spanning-tree mode pvst

interface Loopback0

ip address 4.4.4.4 255.255.255.255

interface GigabitEthernet0/0

ip address 10.4.1.1 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/1

ip address 192.168.3.2 255.255.255.0

duplex auto

speed auto

interface Vlan1

no ip address

shutdown

router ospf 1

log-adjacency-changes

network 192.168.3.0 0.0.0.255 area 2

network 10.4.1.0 0.0.0.255 area 2

ip classless

ip flow-export version 9

line con 0

line aux 0

line vty 0 4

login

end

配置计算机

P0配置:

P1配置:

路由表信息

这里仅展示R2和R4路由表,自己动手丰衣足食,另外两个自行查询,命令是Router#sh ip ro

R2路由表信息

R4路由表信息

连通性测试

PC0 ping R4PC1

PC1 ping R1PC0

实验文档下载

该附件已被管理员隐藏 您需要 回复 后并刷新才可以下载
分享到:
打赏
-版权声明-

阅读时间:  发布于:2020-5-31
文章标题:《OSPF路由重分发 孙阳 高级路由》
本文链接:https://www.mua222.cn/196.html
本文编辑: 小浣熊,转载请注明超链接和出处小浣熊博客
收录状态:[百度已收录][360已收录][搜狗已收录]

评论

     快速回复: 支持 感谢 学习 不错 高兴 给力 加油 惊喜
  1. #7
    42游客 Lv.1  Chrome 83.0.4103.116 Chrome 83.0.4103.116 Windows Windows

    人傻了

  2. #6
    Spectre游客 Lv.2  Chrome 70.0.3538.25 Chrome 70.0.3538.25 Windows Windows

    才发现这个作业

  3. #5
    85号奶盖游客 Lv.3  Chrome 78.0.3904.108 Chrome 78.0.3904.108 Windows Windows

    大鼎!

  4. #4
    游客 Lv.2  Chrome 70.0.3538.25 Chrome 70.0.3538.25 Windows 7 x64 Edition Windows 7 x64 Edition

    刘哔啊老铁

  5. #3
    小小的奋斗游客 Lv.1  Chrome  Chrome  Android 8.1.0 Android 8.1.0

    看起来好像不错的样子

  6. #2
    ♂陨极光游客 Lv.1  Chrome 78.0.3904.108 Chrome 78.0.3904.108 Windows Windows

    挺有帮助的

  7. #1
    85号奶盖游客 Lv.3  Chrome 70.0.3538.102 Chrome 70.0.3538.102 Windows Windows

    日常迷茫

切换注册

登录

忘记密码?

您也可以使用第三方帐号快捷登录

切换登录

注册

OSPF路由重分发 孙阳 高级路由

长按图片转发给朋友

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏